The Unity Package Manager allows you to install the package and easily keep it up to date. It also automatically installs dependencies such as the Burst compiler (though dependency resolution in UPM can be a bit tricky sometimes).

Installing using the package manager requires Unity 2019.3.0f3 or higher.

UPM installation guide

Enter your Unity Asset Store invoice number to continue. If you purchased it on this website instead of the Unity Asset Store then enter your license key.

You can find your Asset Store invoice number on the pdf invoice that Unity sends you when you complete a purchase.